PHTML Encoder

張貼者:2010年9月6日 下午10:53未知的使用者   [ eddie liu 已於 2012年8月8日 上午3:31 更新 ]
PHTML Encoder PRO under LinuxPHTML編碼器(前身- PHP的編碼器)允許編碼的PHP腳本之前分發它們。 該腳本代碼的邏輯是保存在使用加密技術來隱藏你的邏輯不被窺視。 這是可能的預定義腳本編碼鎖機(Web服務器)通過機器ID,這樣你的腳本將只能在本機。 您可以使用自可解腳本,不需要任何更改您的PHP安裝。 由於PHTML編碼器是一種跨平台的產品,該軟件將在所有的電腦和服務器平台的支持PHP。 該PHTML編碼器包括控制台和GUI版本的轉換器,加密/解密你的腳本。 您可以使用通配符來輕鬆轉換整個項目。 該PHTML編碼器是透明的訪問者。 這是可能的保護和不受保護的腳本結合在一個網站上。






開發商:RS Software
原廠網址:http://www.rssoftlab.com/phpenc.php
更新日期:2011/05/29
採購正式版、大量授權報價、技術支援、軟體諮詢、委託採購、詢問報價請來電 02-29299388 分機16 , 
來信service@orderble.com,或點我
-----------------------------------------------------------------------------









特點

PHTML編碼器具有以下特點與比較類似產品:

1。 PHTML編碼器使用加密保護的PHP腳本。 這是更安全。

2。 這是可能 鎖定 編碼的腳本 預先定義的機器 (Web服務器)通過機器ID,這樣你的腳本將只能在本機。

3。 你可以得到完整的源代碼 PHTML編碼器。 這允許您自定義PHTML編碼器,以滿足您的需求:你可以更改密碼,前綴,添加自己的加密方法,等等。

4。 由於PHTML編碼器是 跨平台產品,該軟件工作在所有計算機和網絡服務器平台,支持PHP。 目前的分配包括版本用於Windows,Linux操作系統的x86,Linux x86上的64位的FreeBSD的x86,FreeBSD的86 64位的Solaris x86,Mac OS X上的編碼腳本從一台計算機平台將在任何其他平台。 所有版本的PHP 4.2.0-4.4.9之間,5.0.0-5.2.13和5.3.0-5.3.2支持。

5。 有 三種方式的使用編碼腳本:PHP引擎替代的存在的庫文件,安裝為PHP擴展和 自我decodeable腳本 在最後一種情況下你不需要任何改變PHP安裝。






Features

PHTML Encoder has following features with comparison analogous products:

1. PHTML Encoder uses cryptography for protection of PHP scripts. This is more secure.

2. It is possible to lock encoded scripts to predefined machine (Web server) via machine ID so your scripts will work only on this machine.

3. You can get the completed source code of PHTML Encoder. This allows you to customize PHTML Encoder to meet your needs: you can change password, prefix, add own cryptography method, and so on.

4. Because PHTML Encoder is cross-platform product, this software working on ALL computer and web-server platforms, which support PHP. Current distributive include version for for for Windows, Linux x86, Linux x86 64 bit, FreeBSD x86, FreeBSD x86 64 bit, Solaris x86, Mac OS X. The encoded scripts from one computer platform will work on any other platform. All versions of PHP between 4.2.0-4.4.9, 5.0.0-5.2.13 and 5.3.0-5.3.2 are supported.

5. There are three ways of usage encoded scripts: substitution of existent PHP engine's library file, installation as PHP extension and self-decodeable scripts. In last case you don't need any changes in PHP installations.